Home    Forum    Search    FAQ    Register    Log in


Post new topic  Reply to topic 
Page 1 of 1
 
 
mediatomb install
Author Message
Reply with quote Download Post 
Post mediatomb install 
 
I'd like to firstly say a huge "thank you  Laughing " for the fantastic work with the  35HD-DUAL-NAS and the tinky-ls firmware it was sooo easy to install and everything worked.

I had a look at twonkymedia, it installed fine once I had formatted both drives and I had IDE1 up and running.  But was wasn't impressed with the interface.

So I'd like to try and get Mediatomb running but when I ran the ipkg-cl install mediatomb I get the following errors:

Quote:
Downloading http://www.nas-2000.org/download/ti...0.0_armv4tl.ipk
ipkg: Unknown typeflag: 0x4c: Illegal seek
ipkg: Unknown typeflag: 0x4c: Illegal seek
ipkg: Unknown typeflag: 0x4c: Illegal seek
ipkg: Unknown typeflag: 0x4c: Illegal seek
ipkg: Unknown typeflag: 0x4c: Illegal seek
ipkg: Unknown typeflag: 0x4c: Illegal seek
ipkg: Unknown typeflag: 0x4c: Illegal seek
ipkg: Unknown typeflag: 0x4c: Illegal seek
ipkg: Unknown typeflag: 0x4c: Illegal seek
ipkg: Don't know how to handle /./@LongLink: No such file or directory
Configuring mediatomb
//system/overlay/apps/ipkg/info/mediatomb.postinst: line 4: /system/overlay/rc.d/S72mediatomb: not found
postinst script returned status 127
ERROR: mediatomb.postinst returned 127
Successfully terminated.


Any ideas?

thanks
 



 
View user's profileSend private message 
Back to topPage bottom
Reply with quote Download Post 
Post Re: Mediatomb Install 
 
Same problem.
I would like to try mediatomb because Twonky is commercial product.

Downloading http://www.nas-2000.org/download/ti...0.0_armv4tl.ipk
ipkg: Unknown typeflag: 0x4c: Illegal seek
ipkg: Unknown typeflag: 0x4c: Illegal seek
ipkg: Unknown typeflag: 0x4c: Illegal seek
ipkg: Unknown typeflag: 0x4c: Illegal seek
ipkg: Unknown typeflag: 0x4c: Illegal seek
ipkg: Unknown typeflag: 0x4c: Illegal seek
ipkg: Unknown typeflag: 0x4c: Illegal seek
ipkg: Unknown typeflag: 0x4c: Illegal seek
Installing libmagic (1.0) to root...
Downloading http://www.nas-2000.org/download/ti...1.0_armv4tl.ipk
Installing libid3 (3.8) to root...
Downloading http://www.nas-2000.org/download/ti...3.8_armv4tl.ipk
Installing libexif (12.0.1) to root...
Downloading http://www.nas-2000.org/download/ti...0.1_armv4tl.ipk
Installing libsqlite (0.8.6) to root...
Downloading http://www.nas-2000.org/download/ti...8.6_armv4tl.ipk
Installing libid3tag (3.8) to root...
Downloading http://www.nas-2000.org/download/ti...3.8_armv4tl.ipk
Installing libz (0.1) to root...
Downloading http://www.nas-2000.org/download/ti...0.1_armv4tl.ipk
Installing libstdc++ (0.1) to root...
Downloading http://www.nas-2000.org/download/ti...0.1_armv4tl.ipk
Installing libjs (0.1) to root...
Downloading http://www.nas-2000.org/download/ti...0.1_armv4tl.ipk
ipkg: Unknown typeflag: 0x4c: Illegal seek
ipkg: Don't know how to handle /./@LongLink: No such file or directory
Configuring libexif
Configuring libid3
Configuring libid3tag
Configuring libjs
Configuring libmagic
Configuring libsqlite
Configuring libstdc++
Configuring libz
Configuring mediatomb
//system/overlay/apps/ipkg/info/mediatomb.postinst: line 4: /system/overlay/rc.d/S72mediatomb: not found
postinst script returned status 127
ERROR: mediatomb.postinst returned 127
Successfully terminated.


Anyone got an idee ?
TY
 




____________
35HD-DUAL-NAS-E Tinky-LS DCTCS
 
View user's profileSend private message 
Back to topPage bottom
Reply with quote Download Post 
Post Re: Mediatomb Install 
 
Hi,

Same problem here. Any idea?

regards,
VarnYu
 



 
View user's profileSend private message 
Back to topPage bottom
Reply with quote Download Post 
Post Re: Mediatomb Install 
 
Hi,
copy /system/overlay/lib/libexif.so.12/lib* in /usr/lib to resolve...

But I've another problem.
I'm start mediatomb command


MediaTomb UPnP Server version 0.10.0 - http://mediatomb.cc/

===============================================================================
Copyright 2005-2007 Gena Batsyan, Sergey Bostandzhyan, Leonhard Wimmer.
MediaTomb is free software, covered by the GNU General Public License version 2

2007-03-27 16:51:27    INFO: Loading configuration from: /root/.mediatomb/config.xml
2007-03-27 16:51:27    INFO: Checking configuration...
2007-03-27 16:51:27    INFO: Config: option not found: /server/servedir using default value:
2007-03-27 16:51:27    INFO: Config: option not found: /server/ui/attribute::poll-when-idle using default value: no
2007-03-27 16:51:27    INFO: Config: option not found: /server/ui/attribute::poll-interval using default value: 2
2007-03-27 16:51:27    INFO: Config: option not found: /server/ui/items-per-page/attribute::default using default value: 25
2007-03-27 16:51:27    INFO: Config: option not found: /import/mappings/extension-mimetype/attribute::ignore-unknown using default value: no
2007-03-27 16:51:27    INFO: Config: option not found: /import/filesystem-charset using default value: ANSI_X3.4-1968
2007-03-27 16:51:27    INFO: Setting filesystem import charset to ANSI_X3.4-1968
2007-03-27 16:51:27    INFO: Config: option not found: /import/metadata-charset using default value: ANSI_X3.4-1968
2007-03-27 16:51:27    INFO: Setting metadata import charset to ANSI_X3.4-1968
2007-03-27 16:51:27    INFO: Config: option not found: /import/playlist-charset using default value: ANSI_X3.4-1968
2007-03-27 16:51:27    INFO: Setting playlist charset to ANSI_X3.4-1968
2007-03-27 16:51:27    INFO: Config: option not found: /server/protocolInfo/attribute::extend using default value: no
2007-03-27 16:51:27    INFO: Config: option not found: /server/pc-directory/attribute::upnp-hide using default value: no
2007-03-27 16:51:27    INFO: Config: option not found: /server/retries-on-timeout using default value: 0
2007-03-27 16:51:27    INFO: Config: option not found: /server/interface using default value:
2007-03-27 16:51:27    INFO: Config: option not found: /server/ip using default value:
2007-03-27 16:51:27    INFO: Config: option not found: /server/bookmark using default value: mediatomb.html
2007-03-27 16:51:27    INFO: Config: option not found: /server/modelName using default value: MediaTomb
2007-03-27 16:51:27    INFO: Config: option not found: /server/modelDescription using default value: Free UPnP AV MediaServer, GNU GPL
2007-03-27 16:51:27    INFO: Config: option not found: /server/modelNumber using default value: 0.10.0
2007-03-27 16:51:27    INFO: Config: option not found: /server/serialNumber using default value: 1
2007-03-27 16:51:27    INFO: Config: option not found: /server/manufacturerURL using default value: http://mediatomb.cc/
2007-03-27 16:51:27    INFO: Config: option not found: /server/presentationURL using default value:
2007-03-27 16:51:27    INFO: Config: option not found: /server/presentationURL/attribute::append-to using default value: none
2007-03-27 16:51:27    INFO: Config: option not found: /server/upnp-string-limit using default value: -1
2007-03-27 16:51:27    INFO: Config: option not found: /import/scripting/playlist-script/attribute::create-link using default value: yes
2007-03-27 16:51:27    INFO: Config: option not found: /server/port using default value: 0
2007-03-27 16:51:27    INFO: Config: option not found: /server/alive using default value: 180
2007-03-27 16:51:27    INFO: Config: option not found: /import/mappings/mimetype-upnpclass using default value:
2007-03-27 16:51:27    INFO: Config: option not found: /import/autoscan using default value:
2007-03-27 16:51:27    INFO: Config: option not found: /import/library-options/libexif/auxdata using default value:
2007-03-27 16:51:27    INFO: Config: option not found: /import/magic-file using default value:
2007-03-27 16:51:27    INFO: Configuration check succeeded.
2007-03-27 16:51:29    INFO: Initialized port: 49152
2007-03-27 16:51:29    INFO: Server bound to: x.x.x.x
2007-03-27 16:51:30 WARNING: magic_load: could not find any magic files!
2007-03-27 16:51:30    INFO: MediaTomb Web UI can be reached by following this link:
2007-03-27 16:51:30    INFO: http://x.x.x.x:49152/

When i open http://ip:49152, i've a 404 Not Found result page..

Any idea?
Bye
Mario
 



 
View user's profileSend private message 
Back to topPage bottom
Reply with quote Download Post 
Post Re: Mediatomb Install 
 
Mario,

i read about a similar problem.

mediatomb could not find a suitable home-area.

solution was to add that area to the argument line in /etc/init.d/mediatomb
they said: add to the linbe called "D_ARGS" this: -m /var/lib/mediatomb

hope this helps.

best of luck

ww
 



 
View user's profileSend private message 
Back to topPage bottom
Reply with quote Download Post 
Post Re: Mediatomb Install 
 
wireless wonder wrote: [View Post]
Mario,

i read about a similar problem.

mediatomb could not find a suitable home-area.

solution was to add that area to the argument line in /etc/init.d/mediatomb
they said: add to the linbe called "D_ARGS" this: -m /var/lib/mediatomb

hope this helps.

best of luck

ww


Sorry but i can't find /etc/init.d/mediatomb
 



 
View user's profileSend private message 
Back to topPage bottom
Reply with quote Download Post 
Post Re: Mediatomb Install 
 
Hi,

I'm trying to find out how to get Media tomb on my NAS , is there a walkthrough on the site anywhere i can use ?

Is it possible to install on the original firmware ? or do i need to use Tinky ?

Also has anyone got this going sucessfully yet ?
 



 
View user's profileSend private message 
Back to topPage bottom
Reply with quote Download Post 
Post Re: Mediatomb Install 
 
ziomaruo wrote: [View Post]
wireless wonder wrote: [View Post]
Mario,

i read about a similar problem.

mediatomb could not find a suitable home-area.

solution was to add that area to the argument line in /etc/init.d/mediatomb
they said: add to the linbe called "D_ARGS" this: -m /var/lib/mediatomb

hope this helps.

best of luck

ww


Sorry but i can't find /etc/init.d/mediatomb

Can't find it because you have used the armv4 version, this an ready-compiled file, so no file in /etc/init.d/mediatomb is normal, u can only start it by abs file path:
# /usb/sda1/mediatomb/usr/bin/mediatomb -m /usb/sda1/mediatomb -f config
something like this.
 



 
View user's profileSend private message 
Back to topPage bottom
Display posts from previous:   
 

Post new topic  Reply to topic  Page 1 of 1
 

Users browsing this topic: 0 Registered, 0 Hidden and 0 Guests
Registered Users: None


 
Permissions List
You cannot post new topics
You cannot reply to topics
You cannot edit your posts
You cannot delete your posts
You cannot vote in polls
You can attach files
You can download files
You can post calendar events